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Phone Modeler User Guide

Preface

This preface includes the purpose of this User Guide, intended Target Audience and
Organization.

Purpose
This guide will provide the user of the Cisco IP Phone Modeler with an overview of the product . It
will also provide a detailed explanation on how to easily use the Phone Modeler and its varied
features.

This application works in tandem with the Cisco IP Phone to deliver several high-end features.
These are discussed in detail in later sections.

Target Audience

The Phone Modeler is for existing Cisco IP Telephony Customers who have in house expertise to
develop and deploy XML Applications to the 79xx phones; for Cisco IP Telephony Partners who
want to model Cisco IP Phone Services for sales and deployment purposes; for those who sell
Cisco IP Telephony solutions and want to model and demonstrate the capabilities of the Cisco IP
Phone, and finally for anyone who is simply interested in developing applications for the Cisco IP
Telephony Environment.

You can make use of the Phone Modeler to program in XML, and customize your Cisco IP Phone
to deliver various functionalities.

Organization of this User Guide

This guide has several sections. These are:

Introduction
Hardware and Software Requirements
Interoperability with the Cisco IP Phone
Installation
Getting Started
Phone Modeler Fields and Utilities
All About Menus
All About Phone Objects
How to Add and Delete SoftKeys
How to Add and Delete MenuItems
The Connector: How it Works
What is the Emulator?
Frequently Asked Questions
Conclusion
Related Documentation
Appendix
Glossary
Index
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Introduction

This User Guide introduces the Cisco IP Phone Modeler and describes its features, how they
work and how they add several valuable functionalities to your Cisco IP Phone. By using the
Phone Modeler, you can customize your IP phone by creating an XML model that automatically
displays as text or graphics. In effect, the Phone Modeler is a translator between you and your
Cisco IP Phone.

What is the Cisco IP Phone Modeler?

The Cisco IP Phone Modeler is a software application developed by Cistera Networks that acts
as an independent add-on tool for Cisco IP Phones. It is a GUI-based application that allows
users to quickly model and publish phone services based on XML—delivering a wide range of
functionalities, as well as several sophisticated features. Extensible Markup Language, or XML, is
the programming language that creates text and graphics for the IP phone. Phone Modeler allows
you to customize your phone without using complicated programming concepts.

This application gives users, customers and IPT administrators a means to easily build XML
applications for the Cisco 79xx IP phones

The overall objective is to create a robust modeling tool for Cisco 79xx phones that anyone can
use to build and deploy XML Applications on these Phones.

Why Use the Phone Modeler?

Your Cisco IP Phone Modeler allows you to add numerous customized functions to your phone,
including:

• Adding contacts to your Company Directory and viewing the information on your Cisco IP
Phone.

• Tracking personal stock information.
• Displaying your Company Logo.
• Tracking weather information.
• Streamlining phone navigation. For example, you can click on the Company Logo to go

directly to the Company Directory.
• Displaying your to-do list.
• Displaying dynamic information, such as personal objectives.
• Tracking sales by displaying a sales graph.
• Displaying marketing statistics.
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Hardware and Software Requirements

The Phone Modeler requires the following:

Hardware

• Desktop running Windows NT/95/98/2000/XP
• 128 MB available memory
• Cisco IP Phone 7960 or 7970

Software

• Java Runtime Environment version 1.4.2 or greater
• Windows NT/95/98/2000/XP
• Cisco Phone Services Simulator



CN-UG (PM)-06-2005-0.4 5

Interoperability with the Cisco IP Phone

The Phone Modeler application is compatible with the 7960 and 7970 Cisco IP Phone models.
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Installation

Follow these steps to confirm that the desktop does not already have Java Webstart installed:
1. Go to Control Programs
2. Add or Remove Programs
3. If Java files are present, version 1.4.1 or earlier, remove them
4. If supported Java files are present, skip the next section

Installing Java Webstart
1. Install the Java WebStart from http://java.sun.com.
http://java.sun.com/j2se/1.4.2/download.html

2.Click on the link that says: Download 1.4.2 JRE/SDK

3.Follow the prompts for installing Java Webstart after you have completed the download.

Installing Cistera Networks Phone Modeler

1. Click on the PhoneModelerSetup.exe file, which starts the installer and the standard
installation process.

2. Follow the steps in sequence to install the Phone Modeler.

3. You will see two files in your directory after installation. Both will say ‘PhoneModeler 1-1’.
One will be a jar file and the other will be a batch file.

4. Doubleclick on either file to launch the application.

Figure 1: Double-click the jar or batch file to launch the Phone Modeler

The Phone
Modeler 1-1
jar and
batch files
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Getting Started

1. This is how the initial interface of the Phone Modeler application looks like once it is
launched. Click on the center icon to begin using the application:

Figure 2: The interface when the Phone Modeler application is launched

2. Once the icon is clicked, it disappears. Now click on File > New to create a new application.

Figure 3: A New File being opened

Click on this
icon to begin
using the
Phone
Modeler
application
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3. Choose the model of the Cisco IP Phone that you wish to customize by clicking on the
appropriate button. Click OK.

Figure 4: The Phone Model setting opens up

4. Upon clicking 7960, the following interface opens up.

Figure 5: This interface opens up on clicking 7960
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€ NOTE: Depending on phone model, certain objects will be disabled. Three objects are
disabled with the 7960, but all are available with the 7970. . CiscoIPPhoneImageFile,
CiscoIPGraphicFileMenu and CiscoIPPhoneIconFileMenu objects are not available on the
7960.

Once you’ve reached the above interface, you can begin utilizing the phone objects and menus
as outlined in subsequent sections.
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Phone Modeler Fields and Utilities

The Phone Modeler has several fields that can be used to add various phone objects and menus
to the Cisco IP Phone.

The Menus toolbar includes:
• File
• Edit
• Align
• Attributes
• Window
• Emulator
• About

The Phone Objects toolbar has ten objects that can be dragged and dropped onto the Drawing
Pane. Data about each phone object can be entered into the Edit Pane.  A tab for a particular
phone object appears in the Tree Pane.

Figure 6: The different fields and panes of the Phone Modeler interface

Menus

The Phone
Objects
Toolbar

Drawing
Pane

Tree Pane Edit Pane
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 All About Menus

The Phone Modeler has several menus that serve different functions. Using these menus you can
open or save a file, export XML, group together objects, bring objects to the front or back, select
and align objects, fill color, and launch the emulator.

What are they?

These menus are:

• File
• Edit
• Align
• Attributes
• Window
• Emulator
• About

How do they work?

1. Click on the phone object you want to select and drag and drop into the field below.
2. Now select the object(s) and alter its properties using the various menus. For example,

click on Edit and then select ‘Group’.
3. You can also click on Align and then select ‘Lefts’, ‘Rights’, ‘Tops’, ‘Bottoms’ or ‘Centers’.

This alignment is for visual purposes only and does not align the phone object(s) within
the IP Phone.

4. You can also click on Window to open a new window.
5. Click on ‘Attributes’ to fill in either pen color or fill color.
6. Click on ‘Emulator’ to launch the Cisco Phone Services Emulator.
7. The ‘About’ menu offers standard software information.

The File Menu

The File Menu allows you to open a new or existing file, save, export XML, print, define
preferences, and exit the application.

To use the File Menu:
• Click on New to open a new file.
• Click on Open to open an already existing file.
• Click Save to save a file.
• Click Export XML to convert objects into XML, which will then be displayed as text or

graphics on your phone.
• Click Print to print the screen.
• Click Preferences to detail where the XML will be exported to on your machine.
• Click Exit to close the screen.

The File menu has an Exporting XML option, as well as a Preferences option.
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Exporting XML

Why is this done?

You need to export XML in order to convert the graphical phone objects into text and graphics
that are visible on your Cisco IP Phone. The phone objects are XML, but without exporting XML
they are simply squares and arrows. Exporting XML allows you to convert these objects into
varied applications for the Cisco IP Phone.

The phone objects used to create the drawing should be connected to each other using a URL,
which is comprised of the server’s Machine IP address, the server’s Port Number and the
Application Name. The initial data in the URL is based on the data in the
PhoneModeler.Properties file. However, while exporting, these can be reset with the parameters
entered during export.

How is this done?

1. Once you have entered information into one or several phone objects, click Export XML
on the File menu.
2. Once you click Export XML the following screen opens up:

Figure 7:The Export XML screen opens up

The default values can be overridden with new values, if necessary.
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3. Click Export to place the files in the appropriate folder:

Figure 8: The Export XML dialog box opens up

What happens when this is done?

Once XML is exported, Phone Objects are transformed into text and graphics for your Cisco IP
Phone. You can view the changes using the Emulator.

Figure 9: The Emulator with information displayed after exporting XML
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Preferences

Preferences define a Properties file that is used at the time of Exporting XML. It determines
where the XML will be exported. Once the XML is exported you can view it on your Emulator. See
Emulator section.

It also determines the Machine IP and Port on which the server is running. Upon clicking
Preferences on the File menu, the following screen opens up:

Figure 10: The Preferences Options Dialog Box

• The Machine IP Address is the IP address of the computer on which the server is
running.

• The Port Number is the port at which the server is running. This field can be left blank.
• The Application Name is the route context name for your application, which the server will

use to recognize your application.
• The Export XML path is the path at which you are storing your XMLs generated by the

Phone Modeler, which are then used by the Emulator. The File Chooser button on the
right side of the Export XML path field allows the user to choose the output location to
export the XMLs.

• Generate XML with Header when selected will generate the output XML with standard
XML header.
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The Edit Menu

Once you select either one or more phone objects, the Edit menu allows you to select or delete
objects; group and ungroup objects; align objects from front to back; and undo or redo command.
Using the Group option you can group multiple objects.

To use the Edit Menu:
• Click Select All to select all phone objects on the drawing pane.
• Click Cut to cut one or more objects.
• Click Copy to copy one or more objects to the clipboard.
• Click Paste to paste one or more objects from the clipboard.
• Click Duplicate to create the direct duplicate of a particular object.
• Click Delete to delete one or more objects.
• Click Group to group either two or more objects. You can group multiple objects.
• Click Ungroup to ungroup the grouped objects.
• Click Send to Back to send selected object(s) to the back.
• Click Bring to Front to bring the selected object(s) to the front.
• Click Undo Command to undo the previous command.
• Click Redo Command to repeat the prior command.

The Align Menu

The Align menu allows you to align the objects left, center, right, top, middle or bottom; or to
group two or more objects.

To use the Align Menu:
• Click Lefts to align the objects on their left edge.
• Click Centers to align the objects centrally.
• Click Rights to align the objects on their right edge.
• Click Tops to align the top edge of all objects.
• Click Middles to align the objects to the middle.
• Click Bottoms to align the bottom edge of all objects with each other.

The Attributes Menu

The Attributes menu enables you to select Pen Color, Fill Color and Arrow.

To use the Attributes Menu:

• Click Fill Color to color an object.
• Click on Pen Color to color the outline of an object.
• Click on Arrow to choose the direction of the Connector – either none, at start, at end or

at both.
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The Window Menu

The Window Menu can open up a New window, or it can give you a choice of Cascade and Tile
on clicking the Window List.

Click New Window to open multiple new windows. Phone Objects can be copied from one
window to the other using the Copy and Paste menu options.

The Windows List tab shows all the open windows.

The Emulator Menu

Click on the Emulator menu to launch the Cisco Phone Services Emulator.

The About Menu

The About Menu gives you version information about the Phone Modeler.
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All About Phone Objects

The Phone Modeler Phone Objects include:

• CiscoIPPhoneText
• CiscoIPPhoneMenu
• CiscoIPPhoneInput
• CiscoIPPhoneDirectory
• CiscoIPPhoneImage
• CiscoIPPhoneGraphicMenu
• CiscoIPPhoneIconMenu
• CiscoIPPhoneImageFile*
• CiscoIPPhoneGraphicFileMenu*
• CiscoIPPhoneIconFileMenu*

* Not available on the 7960 model.

What are they and why are they used?
XML-based phone objects enable IP phone customization by adding icons, graphs, directories,
organizational charts and other sophisticated features directly to your IP phone display.  Some
displayable information includes:

• Weather
• Stock Information
• Contact Information
• Company News
• To-do lists
• Daily schedule

Cisco IP Phones allow navigation to different text and graphics delivered by the phone objects by
simply utilizing the DTMF keys.

To customize the IP phone interface, objects need to be dragged and dropped into the Cisco IP
Phone Modeler drawing pane. After this is done, the Edit pane presents fields where information
can be entered about individual phone objects. Some of the information entered includes Title,
Prompt, Text, as well as SoftKey Items.

To confirm the changes, you must click Update, which will add the same information on the
corresponding phone.

Drag-Drop

This is a default selection. When none of the Phone Objects are selected, the Drag-Drop option,
when enabled, is highlighted:



CN-UG (PM)-06-2005-0.4 18

Figure 11: The default Drag-Drop button on the Phone Objects toolbar

CiscoIPPhoneText

The CiscoIPPhoneText XML object displays ordinary 8-bit ASCII text on the phone display. ASCII
text includes alphabets and numbers. The <text> message must not contain any control
characters, except for carriage returns, line feeds and tabs.

Definition

<CiscoIPPhoneText>
       <Title>Title text goes here</Title>
       <Prompt>The prompt text goes here</Prompt>
       <Text>The text to be displayed as the message body goes here</Text>
<SoftKeyItem>
   <Name>Name of soft key</Name>
   <URL>URL or URI of soft key</URL>
   <Position>Position information of the soft key</Position>
 </SoftKeyItem>
</CiscoIPPhoneText>

The procedure for using the CiscoIPPhoneText object is:

1. Click on the CiscoIPPhoneText tool button on the Phone Objects toolbar.

Figure 12: The CiscoIPPhoneText tool button selected
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2. Click the CiscoIPPhoneText button and then click onto the Drawing Pane.

Figure 13: The CiscoIPPhoneText object displayed on the Drawing Pane

3. Enter relevant data into the Edit pane and click the Update button. This information will be
visible on the CiscoIPPhoneText object icon.

Figure 14: Relevant data entered into the Edit Pane

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneText object:
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Properties Valid Values
PhoneText Object Name Alphanumeric Characters without spaces
Title Text
Prompt Text
Text Text
Name Text
Position Integers from 0 to 16
URL No restrictions

You can add multiple SoftKey items, as well as delete SoftKey items for this phone object. See
How to Add and Delete SoftKeys.

CiscoIPPhoneMenu

A menu on the phone comprises of a list of text items, one per line. Users choose and load
individual menu items, which behave the same as built-in phone menus. The user navigates and
chooses the menu item using either the Select SoftKey or the DTMF keys.

Definition

<CiscoIPPhoneMenu>
  <Title>Title text goes here</Title>
  <Prompt>Prompt text goes here</Prompt>
  <MenuItem>
   <Name>The name of each menu item</Name>
   <URL>The URL associated with the menu item</URL>
  </MenuItem>
  <SoftKeyItem>
   <Name>Name of soft key</Name>
   <URL>URL or URI of soft key</URL>
   <Position>Position information of the soft key</Position>
  </SoftKeyItem>
</CiscoIPPhoneMenu>

The procedure for using the CiscoIPPhoneMenu object is:

1. Click the CiscoIPPhoneMenu toolbar button on the Phone Objects toolbar.
2. Click the CiscoIPPhoneMenu button and then click onto the Drawing pane.
3.   Enter the relevant information for this phone object into the Edit pane and click the
Update button. This information will be visible on the CiscoIPPhoneMenu object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneMenu object:

Properties Valid Values
PhoneMenu Object Name Alphanumeric characters without spaces
Title Text
Prompt Text
Name Text
URL No restrictions
Position Integers from 0 to 16
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After the user chooses a menu option, the phone generates an HTTP request for the page with
the URL or executes the uniform resource identified (URIs) that are associated with the menu
item.

You can add multiple menu items and soft key items, as well as delete menu items and SoftKey
items for this phone object. See How to Add and Delete SoftKeys and How to Add and Delete
MenuItems.

CiscoIPPhoneInput

When a Cisco IP Phone receives an XML object of type CiscoIPPhoneInput, it constructs an input
form and displays it. As a user, you can then enter data into each input item and send the
parameters to the target URL.

Definition

<CiscoIPPhoneInput>
   <Title>Directory title goes here</Title>
   <Prompt>Prompt text goes here</Prompt>
   <URL>The target URL for the completed input goes here</URL>
   <InputItem>
   <DisplayName>Name of the input field to display</DisplayName>
   <QueryStringParam>The parameter to be added to the target URL</QueryStringParam>
   <DefaultValue>The default display name</DefaultValue>
   <InputFlags>The flag specifying the type of allowable input</InputFlags>
  </InputItem>
  <SoftKeyItem>
   <Name>Name of soft key</Name>
   <URL>URL or URI of soft key</URL>
   <Position>Position information of the soft key</Position>
  </SoftKeyItem>
<CiscoIPPhoneInput>

The procedure for using the CiscoIPPhoneInput object is:

1. Click the CiscoIPPhoneInput button on the Phone Objects toolbar.
2. Click the CiscoIPPhoneInput button and then click onto the Drawing Pane.
3.   Enter the relevant information into the Edit Pane and click the Update button. This
information will be visible on the CiscoIPPhoneInput object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneInput object:

Properties Valid Values
PhoneInput Object Name Alphanumeric characters without spaces
Title Text
Prompt Text
URL No restrictions
DisplayName Text
QueryStringParam Text
DefaultValue Text
Position Integers from 0 to 16
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You can add soft key items, as well as delete SoftKey items for this phone object. See How to
Add and Delete SoftKeys.

CiscoIPPhoneDirectory

For the directory listing, the Cisco IP Phone displays the appropriate SoftKeys that are needed to
dial the numbers listed on the display.

Definition

<CiscoIPPhoneDirectory>
<Title>Directory title goes here</Title>
<Prompt>Prompt text goes here</Prompt>
<DirectoryEntry>
<Name>The name of the directory entry</Name>
<Telephone>The telephone number for the entry</Telephone>
</DirectoryEntry>
<SoftKeyItem>
   <Name>Name of soft key</Name>
   <URL>URL or URI of soft key</URL>
   <Position>Position information of the soft key</Position>
  </SoftKeyItem>
</CiscoIPPhoneDirectory>

The procedure for using the CiscoIPPhoneDirectory object is:

1. Click the CiscoIPPhoneDirectory button on the Phone Objects toolbar.
2. Click the CiscoIPPhoneDirectory button and then click on the Drawing Pane.
3. Enter the relevant information into the Edit Pane and click the Update button. This
information will be visible on the CiscoIPPhoneDirectory object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneDirectory object:

Properties Valid Values
PhoneDirectory Object Name Alphanumeric characters without spaces
Title Text
Prompt Text
Name Text
Telephone Valid telephone characters
URL No restrictions
Position Integers from 0 to 16

You can add multiple soft key items, as well as delete SoftKey items for this phone object. See
How to Add and Delete SoftKeys.

CiscoIPPhoneImage

The CiscoIPPhoneImage provides a bitmap display that can be used to access services.. This
object has the location in the X and Y parameters specified.  The phone uses an LCD display,
which inverts the palette. This object lets you use the Cisco IP Phone display to present graphics
to the user.
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Definition

<CiscoIPPhoneImage>
<Title>Image title goes here</Title>
<Prompt>Prompt text goes here</Prompt>
<LocationX>Position information of graphic</LocationX>
<LocationY>Position information of graphic</LocationY>
<Width>Size information for the graphic</Width>
<Height>Size information for the graphic</Height>
<Depth>Number of bits per pixel</Depth>
<Data>Packed Pixel Data</Data>
<SoftKeyItem>
<Name>Name of the soft key</Name>
<URL>URL of soft key</Name>
<Position>Numerical position of the soft key</Position>
</SoftKeyItem>
</CiscoIPPhoneImage>

The procedure for using the CiscoIPPhoneImage object is:
1. Click the CiscoIPPhoneImage button on the phone objects toolbar.
2. Click the CiscoIPPhoneImage button and then click onto the Drawing Pane.
3.   Enter the relevant data into the Edit Pane and click the Update button. This information
will be visible on the CiscoIPPhoneImage object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneImage object:

Properties Valid Values
PhoneImage Object Name Alphanumeric characters without spaces
Name Text
Title Text
Prompt Text
LocationX Numbers
LocationY Numbers
Width Numbers
Height Numbers
Depth Number between 0 to 2 including both
Data Hexadecimal data
URL No restrictions
Position Integers from 0 to 16

You can add multiple SoftKey items, as well as delete SoftKey items for this phone object. See
How to Add and Delete SoftKeys.

CiscoIPPhoneGraphicMenu

Graphic menus serve the same purpose as text menus; they allow the user to select a URL from
a list. You can use graphic menus in situations when the items may not be easy to display in a
text list.  In such cases, the system presents the information as a bitmap graphic. You can then
enter a number from the DTMF keypad to make a menu selection.
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Definition

<CiscoIPPhoneGraphicMenu>
<Title>Menu title goes here</Title>
<Prompt>Prompt text goes here</Prompt>
<LocationX>Position information of graphic</LocationX>
<LocationY>Position information of graphic</LocationY>
<Width>Size information for the graphic</Width>
<Height>Size information for the graphic</Height>
<Depth>Number of bits per pixel</Depth>
<Data>Packed Pixel Data</Data>
<MenuItem>
<Name>The name of each menu item</Name>
<URL>The URL associated with the menu item</URL>
</MenuItem>
<SoftKeyItem>
   <Name>Name of soft key</Name>
   <URL>URL or URI of soft key</URL>
   <Position>Position information of the soft key</Position>
  </SoftKeyItem>
</CiscoIPPhoneGraphicMenu>

The procedure for using the CiscoIPPhoneGraphicMenu object is:
1. Click the CiscoIPPhoneGraphicMenu button on the phone objects toolbar.
2. Click the CiscoIPPhoneGraphicMenu button and then click onto the Drawing Pane.
3.   Enter the relevant data into the Edit Pane and click the Update button. This information
will be visible on the CiscoIPPhoneGraphicMenu object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneGraphicMenu object:

Properties Valid Values
PhoneGraphicMenu Object Name Alphanumeric characters without spaces
Title Text
Prompt Text
Location X Numbers
Location Y Numbers
Width Numbers
Height Numbers
Depth Numbers between 0 to 2 including both
Data Hexadecimal data
Name Text
URL No restrictions
Position Integers from 0 to 16

You can add multiple menu items and soft key items, as well as delete menu items and SoftKey
items for this phone object. See How to Add and Delete SoftKeys and How to Add and Delete
MenuItems.

CiscoIPPhoneIconMenu

Icon menus serve the same purpose as text menus. They allow you as a user, to select a URL
from a list. You can use icon menus in situations when you want to provide additional visual
information to the user to show the state or category of an item. For example, you can include a
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read and unread icon in a mail viewer. Icons in the CiscoIPPhoneIconMenu object have a
maximum width of 16 pixels and a maximum height of 10 pixels. You can use icons to convey the
message state.

Definition

<CiscoIPPhoneIconMenu>
<Title>Title text goes here</Title>
<Prompt>Prompt text goes here</Prompt>
<MenuItem>
<IconIndex>Indicates what IconItem to display</IconIndex>
<Name>The name of each menu item</Name>
<URL>The URL associated with the menu item</URL>
</MenuItem>
<IconItem>
<Index>A unique index from 0 to 9</Index>
<Height>Size information for the icon</Height>
<Width>Size information for the icon</Width>
<Depth>Number of bits per pixel</Depth>
<Data>Packed Pixel Data</Data>
</IconItem>
<SoftKeyItem>
<Name>Name of soft key</Name>
<URL>URL or URI of soft key</URL>
<Position>Position information of the soft key</Position>
</SoftKeyItem>
</CiscoIPPhoneIconMenu>

The procedure for using the CiscoIPPhoneIconMenu object is:
1. Click the CiscoIPPhoneIconMenu button on the phone objects toolbar.
2. Click the CiscoIPPhoneIconMenu button and then click onto the Drawing Pane.
3. Enter the relevant information into the Edit Pane and click the Update button. This
information will be visible on the CiscoIPPhoneIconMenu object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneIconMenu object:

Properties Valid Values
PhoneIconMenu Object Name Alphanumeric characters without spaces
Title Text
Prompt Text
Name Text
URL No restrictions
IconIndex Integers between 0 to 9
Index Integers between 0 to 9
Width Numbers
Height Numbers
Depth Numbers between 0 to 2 including both
Data Hexadecimal data
Position Integers from 0 to 16

You can add multiple menu items and soft key items, as well as delete menu items and SoftKey
items for this phone object. See How to Add and Delete SoftKeys and How to Add and Delete
MenuItems.
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CiscoIPPhoneImageFile

The latest generation of Cisco IP Phones has higher resolution displays with more color depth.
For example, the Cisco IP Phone 7970 has a display area of 298 x 168 pixels available to the
Services pane and renders images in 12-bit color.

The CiscoIPPhoneImageFile behaves like the CiscoIPPhoneImage object, except for the image
data. Instead of using the <Data> tag to embed the image data, the <url> points to the PNG file.

Definition

<CiscoIPPhoneImageFile>
<Title>Image Title goes here</Title>
<Prompt>Prompt text goes here</Prompt>
<LocationX>Horizontal position of graphic</LocationX>
<LocationY>Vertical position of graphic</LocationY>
<URL>Points to the PNG image</URL>
<SoftKeyItem>
<Name>Name of soft key</Name>
<URL>URL or URI of soft key</URL>
<Position>Position information of the soft key</Position>
</SoftKeyItem>
</CiscoIPPhoneImageFile>

The procedure for using the CiscoIPPhoneImageFile object is:
1. Click on the CiscoIPPhoneImageFile button on the phone objects toolbar.
2. Click the CiscoIPPhoneImageFile button and then click onto the Drawing Pane.
3.   Enter the relevant information into the Edit Pane and click the Update button. This
information will be visible on the CiscoIPPhoneImageFile object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneImageFile object:

Properties Valid Values
PhoneImageFile Object Name Alphanumeric characters without spaces
Name Text
Title Text
Prompt Text
LocationX Numbers
LocationY Numbers
URL No restrictions
Position Integers from 0 to 16

You can add multiple soft key items, as well as delete SoftKey items for this phone object. See
How to Add and Delete SoftKeys.

CiscoIPPhoneGraphicFileMenu

Some of the latest Cisco IP Phone models, such as the Cisco IP Phone 7970 have pointer
devices. The Cisco IP Phone 7970 uses a touchscreen overlay on the display. Because these
phones can receive and process “pointer” events, a CiscoIPPhoneGraphicFileMenu object
exposes the capability to application developers. The CiscoIPPhoneGraphicFile Menu behaves
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similar to the CiscoIPPhoneGraphicMenu, in that a group of options are presented by an image.
When one of those objects is selected, a URL action initiates.

However, the CiscoIPPhoneGraphicFileMenu does not use the keypad, but uses rectangular
touch areas. Coordinates relative to the upper-left corner of the Services display define these
rectangular touch areas.

Definition

<CiscoIPPhoneGraphicFileMenu>
<Title>Image Title goes here</Title>
<Prompt>Prompt text goes here</Prompt>
<LocationX>Horizontal position of graphic</LocationX>
<LocationY>Vertical position of graphic</LocationY>
<URL>Points to the PNG background image</URL>
<MenuItem>
<Name>Same as CiscoIPPhoneGraphicMenu</Name>
<URL>Invoked when the TouchArea is touched</URL>
<TouchArea X1="left edge" Y1="top edge" X2="right edge" Y2="bottom
edge"/>
</MenuItem>
<SoftKeyItem>
<Name>Name of soft key</Name>
<URL>URL or URI of soft key</URL>
<Position>Position information of the soft key</Position>
</SoftKeyItem>
</CiscoIPPhoneGraphicFileMenu>

The procedure for using the CiscoIPPhoneGraphicFileMenu object is:
1. Click the CiscoIPPhoneGraphicFileMenu button on the phone objects toolbar.
2. Click the CiscoIPPhoneGraphicFileMenu button and then click onto the Drawing Pane.
3. Enter the relevant information in the Edit Pane and click the Update button. This
information will be visible on the CiscoIPPhoneGraphicFileMenu object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneGraphicFileMenu object:

Properties Valid Values
PhoneGraphicFileMenu Object Name Alphanumeric characters without spaces
Title Text
Prompt Text
LocationX Numbers
LocationY Numbers
URL No restrictions
Name Text
Position Integers from 0 to 16
TouchAreaX1 Numbers
TouchAreaX2 Numbers
TouchAreaY1 Numbers
TouchAreaY2 Numbers

You can add multiple menu items and soft key items, as well as delete menu items and SoftKey
items for this phone object. See How to Add and Delete SoftKeys and How to Add and Delete
MenuItems.
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CiscoIPPhoneIconFileMenu

This icon menu is similar to the CiscoIPPhoneMenu but it uses color PNG icons rather than
grayscale CIP icons. Use icon menus in situations when you want to provide additional visual
information to the user to show the state or category of an item. For example, you can use icons
to indicate priority.

Icons in the CiscoIPPhoneIconFileMenu object have a maximum width of 18 pixels and a
maximum height of 18 pixels. Instead of using the <Data> tag to embed the image data into the
<IconItem> tag, this object uses a <URL> tag to point to the PNG image file to be used for that
icon.

Definition
<CiscoIPPhoneIconFileMenu>
<Title>Title text goes here</Title>
<Prompt>Prompt text goes here</Prompt>
<MenuItem>
<IconIndex>Indicates what IconItem to display</IconIndex>
<Name>The name of each menu item</Name>
<URL>The URL associated with the menu item</URL>
</MenuItem>
<IconItem>
<Index>A unique index from 0 to 9</Index>
<URL>location of the PNG icon image</URL>
</IconItem>
<SoftKeyItem>
<Name>Name of soft key</Name>
<URL>URL or URI of soft key</URL>
<Position>Position information of the soft key</Position>
</SoftKeyItem>
</CiscoIPPhoneIconFileMenu>

The procedure for using the CiscoIPPhoneIconFileMenu object is:
1. Click the CiscoIPPhoneIconFileMenu button on the phone objects toolbar.
2. Click the CiscoIPPhoneIconFileMenu button and then click onto the Drawing Pane.
3. Enter the relevant information in the Edit Pane and click the Update button. This
information will be visible on the CiscoIPPhoneIconFileMenu object icon.

The following are the properties and valid values for the menu items and SoftKey items for the
CiscoIPPhoneIconFileMenu object:

Properties Valid Values
PhoneIconFileMenu Object Name Alphanumeric characters without spaces
Title Text
Prompt Text
Name Text
URL No restrictions
IconIndex Integers between 0 to 9
Index Integers between 0 to 9
Position Integers from 0 to 16

You can add multiple menu items and soft key items, as well as delete menu items and SoftKey
items for this phone object. See How to Add and Delete SoftKeys and How to Add and Delete
MenuItems.
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How to Add and Delete SoftKeys

SoftKey items have context-sensitive functionalities. The functionality of these SoftKeys keeps
changing all the time. For example, the same key may display ‘End Call’ as well as ‘Redial’. This
is unlike the Number 9 key, which always means Number 9.  You can add or delete SoftKeys as
follows:

1. Click the object button on the Phone Objects toolbar.

Figure 15: The CiscoIPPhoneText toolbar button selected

2. Click onto the Drawing Pane and the object will appear on the pane.

Figure 16: The CiscoIPPhoneText object displayed on the Drawing Pane
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3. A tab for that particular phone object will appear in the Tree Pane.

4. Double click on the tab to reveal the Title, Prompt, Text and SoftKey Item. The latter contains
the Name, Position and URL.

Figure 17: Double clicking on the tab reveals the SoftKey item

5. Right click on the SoftKey Item to reveal a menu that says ‘Add More Soft Keys’ and
‘Delete Soft Key’. Choose the option you want to either add more SoftKeys or delete
SoftKeys.

Figure 18: Right click reveals menu to add or delete SoftKeys

6. This option is available for all phone objects.

SoftKey item
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How to Add and Delete MenuItems

You can add or delete menu items for certain phone objects. These are CiscoIPPhoneMenu,
CiscoIPPhoneGraphicMenu, CiscoIPPhoneIconMenu, CiscoIPPhoneGraphicFileMenu and the
CiscoIPPhoneIconFileMenu objects.

1. Click the object button on the Phone Objects toolbar.

Figure 19: The CiscoIPPhoneMenu toolbar button selected

2. Click onto the Drawing Pane and the object will appear on the pane.
3. A tab for that particular phone object will appear in the Tree Pane.
4. Double click on the tab to reveal the MenuItem.

Figure 20: Doubleclicking on the tab reveals the MenuItem

MenuItem
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5. Right click on the MenuItem to reveal a menu that says ‘Add More Menu Items’ and ‘Delete
Menu Items’. Choose the option you want to either add more MenuItems or delete MenuItems.

Figure 21: Right click reveals a menu to add or delete MenuItems
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The Connector: How it Works

The Connector is a tool on the Phone Object toolbar that enables you to connect two phone
objects and all their information so that they are interconnected by URLs.

To use the connector, click on the first phone object you wish to connect. Then, click on the
Drawing Pane. The phone object will appear on the pane. Repeat this process for the second
phone object. Now click the Connector button on the Phone Objects toolbar. Then, click on the
object from which you wish the Connector to begin and drag and drop the connector onto the
second object you wish to connect to.

Connectors allow you to navigate amongst different functionalities on your Cisco IP Phone. For
example, the CiscoIPPhoneGraphicMenu may display the logo of your company on the phone
display. On selecting this, you can go to company directory information using the
CiscoIPPhoneDirectory object. Connectors allow you to go from one object to another.

Figure 22: The Phone Modeler application with connectors connecting two phone objects
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What is the Emulator?

This is just like a simulator of the Cisco IP Phone, which allows you to view the information you
have entered onto the phone display. Currently, the Emulator supports only the 7960 phone
model, but will soon be available for the 7970 model. Also, the Emulator needs a Windows
environment for it to work.

After dragging and dropping phone objects onto the Drawing Pane, enter information for each
phone object into its respective Edit Pane. Once this is done, you should click on the File Menu
and select Export XML. Now, click the Emulator Menu. Then click the Cisco Phone Services
Emulator option to run the application. You can now view the text or graphics that you have
entered onto the Emulator’s display screen.

The Emulator works in tandem with the Phone Modeler to display the text and graphics that you
have generated in XML. You can view these text and graphics prior to them actually being
transported into your actual Cisco IP Phone model.

What is it used for?

It is used for simulating changes and designs made in Phone Modeler. The Emulator gives users
the opportunity to visualize changes prior to them taking effect on their IP phone.

Be sure to use phone objects first and create a phone model drawing. These will be converted
into XML data during exporting the XML. This actually translates them into real text and graphics
that can be displayed on your Emulator. For the Emulator to work, XML must be exported to the
location where your server is. See Exporting XML.
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Frequently Asked Questions

Q. What should I do if I am unable to start the Phone Modeler?

A: Check that the Java Runtime Environment is installed on your computer. Also, set the
environment variables to Java path.

Q. What should I do if I am unable to start the Emulator?

A: You may not have correctly installed the Emulator. Please check ‘What is the Emulator?’
section.

Q. What should I do if the Emulator shows a ‘Host Not Found’ message on typing the URL
and clicking Enter?

A: This could be due to any one of the following reasons:

• The XML has not been exported before starting the Emulator.
• The IP Address in the Emulator URL is not correct.
• The port number at which your server is running is not the same as the one you have

entered in the Emulator.
• The application name is incorrect.
• The object name you want to see in the Emulator is case sensitive. So, an improper case

can result in a ‘Host Not Found’ message.
• While exporting XMLs the IP address, Port number and Application Name are incorrect.
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Conclusion

The Phone Modeler application is a software application that can be used to customize your
Cisco IP Phone without your knowing complicated programming concepts. Sophisticated
functionalities are easily accessed on your IP phone with an easy-to-use application.

The Phone Modeler makes use of XML-based Phone Objects, as well as menu items that help
add universal appeal. Once information is entered into the Edit Pane for the phone objects you
wish to transport, you then Export XML and these objects now become “live” and are displayed
as text and graphics on your Cisco IP Phone 7960 or 7970.
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Related Documentation

The following documents provide further information:

1) Cistera Phone Modeler Quick Start Guide (Appendix B)
2) Cisco IP Phone Services Application Development Notes (Appendix A)
3) Cisco CallManager Administration Guide
4) Cisco CallManager System Guide
5) Cisco IP Phone 7960/7940 Quick Start Guide
6) Cisco IP Phone Administration Guide for Cisco CallManager
7) CiscoURLProxy Active X Component
8) LDAP Search COM Server Programming Guide
9) CipImage Release Notes
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Appendix

Click here to access the Cisco IP Phone Services Application Development Notes to know more
about the Cisco Phone Objects and relevant programming information for the Cisco IP Phone:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_programming_referen
ce_guide_book09186a00804042de.html
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Glossary

Cisco IP Phone – This is a phone that uses Internet Protocol and XML to display and also offer
the user various functionalities. The user can program this phone to suit their needs. Phone
models 7960 and 7970 are compatible with the Cisco IP Phone Modeler.

Cisco IP Phone Modeler – This is a software application that allows the user to program their
Cisco IP Phone without using or understanding complicated programming concepts. It is
compatible with Cisco IP Phone Models 7960 and 7970.

Cisco Systems Phone Services Emulator – This is like a simulator. It allows you to view the
text and graphics you have exported onto the emulator display screen, so that you can check the
content before it goes live on your Cisco IP Phone.

Connector -- This is a tool in the Phone Modeler, which allows you to connect two or more
objects, so that their properties are linked.

DTMF keys -- Dual-tone multi-frequency (DTMF) is also known as Touch Tone. It is used for
telephone signaling over the line in the voice frequency band to the call switching center. DTMF is
an example of a multi-frequency shift keying (MFSK) system.

Menus – These are drop down menus that offer you various functionalities and options. For
example you can Export XML by clicking an option in the ‘File’ menu or you can change the color
of the phone object by choosing a fill color from the Attributes menu.

Phone Objects – These are XML programs that enable the user to program their Cisco IP Phone
without dealing with complicated programming concepts. Once these phone objects are exported,
they are visible on your Cisco IP Phone as content.

SoftKey Items – These are items (or keys) on the Cisco IP Phone that have no fixed functionality
unlike DTMF keys. The functionality of these SoftKeys keeps changing all the time. For example,
the same keypad button, which is a SoftKey may display ‘End Call’ as well as ‘Redial’.

XML – This stands for Xtensible Markup Language. It is a programming language and it is the
language used in the Phone Modeler that enables you to program your Cisco IP Phone.
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